HaloMD

Post a reply


This question is a means of preventing automated form submissions by spambots.
Smilies
:D :) :( :o :shock: :? 8) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :wink: :!: :?: :idea: :arrow: :| :mrgreen: ----) \ :) / .````:) ?? :( 0) B) O_)
View more smilies

BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON

Topic review
   

Expand view Topic review: HaloMD

Re: HaloMD

Post by nil » Sat Feb 07, 2015 8:09 pm

giambu wrote:Good morning everyone and thank you, it all works very well as the original in its heyday, but now on the mac with Mavericks does not maintain saves in campaign mode. Does anyone know how to fix it ?. Thanks again.


Well HaloMD (being in "demo" form) doesn't really save campaigns since it only comes with one map. I saw an issue with this on the normal Halo retail version, but haven't really checked it out.

Re: HaloMD

Post by Samuco » Tue Feb 03, 2015 5:57 pm

It would be interesting to see if I could replace Halo's scen renderer with Archons crappy legacy one.

Re: HaloMD

Post by 002 » Tue Feb 03, 2015 10:11 am

Guest wrote:by the way, on my imac 27" late 2013, the GPU "GeForce-GT-755M" can render the trees fine on 10.10!
only my macbook air late 2013 i7 with 10.10 cannot render the trees. the GPU is too weak, i think.

Hello. Quite a bit of rendering is defective for the Macbook Air since Halo for the Mac doesn't support Intel graphics. That means the Macbook Air, the Mac Mini, the Macbook Pro (the ones that only have Intel graphics), and the iMac (the ones that only have Intel graphics) aren't going to render it correctly unless you set shaders to vertex shaders only or no shaders. The GPU isn't too weak, it's just not supported.

Re: HaloMD

Post by giambu » Tue Feb 03, 2015 4:56 am

Good morning everyone and thank you, it all works very well as the original in its heyday, but now on the mac with Mavericks does not maintain saves in campaign mode. Does anyone know how to fix it ?. Thanks again.

Re: HaloMD

Post by giambu » Tue Feb 03, 2015 4:55 am

Buongiorno a tutti e grazie, funziona tutto molto bene come l'originale ai tempi d'oro, ma ora sul mac con Mavericks non mantiene i salvataggi in modalità campagna. Qualcuno sa come risolvere il problema?. Grazie ancora.

Re: HaloMD

Post by Guest » Thu Nov 27, 2014 12:11 pm

by the way, on my imac 27" late 2013, the GPU "GeForce-GT-755M" can render the trees fine on 10.10!
only my macbook air late 2013 i7 with 10.10 cannot render the trees. the GPU is too weak, i think.

Re: HaloMD

Post by peppermint » Wed Nov 12, 2014 11:49 pm

thanks for the hint, i installed the extension, and have pixel shaders on,
the trees are still a plain black surface with green elements, no seethrough.
i presume, it is the macbook air late 2013 GPU (intel HD graphics 5000), maybe it cannot render the trees.
so i installed 10.10 on my imac late 2013 (GPU: GeForce-GT-755M) , and i will try if the trees are displayed right there, like it was with 10.9.5

Re: HaloMD

Post by nil » Wed Nov 12, 2014 6:03 pm

I think it affects that graphics card. Try installing 002's "Shader Workaround" extension in the Extensions menu while making sure you have pixel shaders enabled. 002 might have more info on this.

all trees are displayed as plain surface

Post by peppermint » Wed Nov 12, 2014 8:13 am

"all trees are displayed as treetrunk with a plain surface at the top, no leafs, no seethrough"

haloMD runs fine on my imac 2013 with 10.9.5, however i tried the latest version HaloMD 1.0b29, which is compatible with 10.10 on my macbook air 2013 on 10.10 yosemite and it runs fine, too, except all trees are displayed as treetrunk with one plain surface, without any leafs (no seethrough), how can i change this please?

does this "tree" error belong to the macbook air gpu: "Intel HD Graphics 5000" ?

thanks

Re: HaloMD

Post by sparkywhoisbanned » Thu Oct 30, 2014 11:40 am

The following mods have issues:

za_1 -- mod fails; fixable with rebuild
a30_8 -- memory leak
acrophobia_1 -- does not work properly on dedicated server connections
satellite_1 -- mod fails; no easy fix
blizzard_2 -- mod fails; no easy fix
claust_2 -- memory leak
caveteles_2 -- memory leak
ctii_6 -- memory leak
aurtle_1 -- memory leak


HaloMD does not list servers whose port numbers are 2323.

Mod memory leak evidence:
Image

Re: HaloMD

Post by 002 » Sun Oct 19, 2014 12:40 pm

Oh, yes. A new official update was published recently that supports OS X 10.10 (Yosemite). However, support below 10.7 (Lion) was dropped. If you're on 10.6 or earlier, you shouldn't get an update notification anymore.

Re: HaloMD

Post by nil » Sat Oct 18, 2014 9:56 am

Mex Capo wrote:so is there going to be an update soon for Yosemite users ?


Already is.

Re: HaloMD

Post by Mex Capo » Sat Oct 18, 2014 8:28 am

so is there going to be an update soon for Yosemite users ?

Re: HaloMD

Post by 002 » Wed Oct 01, 2014 9:03 pm

Another beta of a beta. I hope this fixes that issue.

http://halomd.macgamingmods.com/HaloMD_b29.zip

Re: HaloMD

Post by Ridog » Tue Sep 30, 2014 9:52 am

002 wrote:There's a new "beta of a beta" release.

http://halomd.macgamingmods.com/HaloMD_b27.zip

It's mostly chat being re-worked. 10.5 support has also been dropped, as well as 32-bit OS X support. It should also work on OS X 10.10 Yosemite.


This breaks in the latest beta release of Yosemite. Crash report: http://pastebin.com/gphrykMD

Top